RangeError: Maximum call stack size

发布时间:2020-06-28 浏览次数:3613 文章来源:个人博客

vue-cli打包报错:

 ERROR  Failed to compile with 1 errors18:19:56

 error  

js/chunk-vendors.985d64f2.js from UglifyJs
RangeError: Maximum call stack size exceeded

这个之前一直没问题,今天使用新jenkins工程打包,就报错了~~

经过排查,是vue-cli3打包的时候,引入了

uglifyjs-webpack-plugin

而这个又依赖

UglifyJs

经过对比发现,如果UglifyJs使用新版本的话,会报错,所以,我们只需要把UglifyJs的版本设置成3.6.9固定版本即可:

npm install uglify-js@3.6.9

再次打包,没问题了。

key-word
uglify-js Maximum uglifyjs-webpack-plugin